Online Class Technical Requirements

The American Feng Shui Institute uses the leading technology available to online schools to give students an ideal learning experience.  The following are the minimum system requirements to participate in our online classes.

Technical requirements for completing the Feng Shui online classes

Computer specifications are reviewed and revised annually to accommodate changes in technology. While every attempt is made to ensure that these specifications satisfy all curricular needs for students completing courses, the AFSI reserves the right to require upgrades in the event of technology changes.

The Courses are web-based or PDF based. While tablets, smartphones and other mobile devices may allow for some completion of coursework, they are not guaranteed to work in all situations. Please ensure you have a Windows or Mac based computer available to complete coursework in the event your selected mobile device does not meet the needs of the course.

The following is the hardware and software needed to complete your online classes at the American Feng Shui Institute:

Supported Operating Systems

  • Windows 8.1 (recommended) or Windows 7, with SP1
  • MAC OS X 10.6 (Snow Leopard) and higher is supported for most online course materials
  • ChromeOS (Chromebooks)

Internet Access

You will need an ISP account for Internet access and an email address. (See more on Internet connectivity specifications below.)

Email Account

A valid email address, which is usually used to verify your login details.

Supported Internet Browsers:

The following are supported browsers.  Browsers are updated often to prevent security issues, fix bugs, and improve your internet experience.  Please have the most current browser software available.   When using older versions of a browser, users risk running into problems with the course software.

Windows OS Users

  • Microsoft Internet Explorer
  • Google Chrome
  • Mozilla Firefox

Mac OS Users

  • Apple Safari
  • Google Chrome
  • Mozilla Firefox

Internet Browsers not mentioned above are NOT currently supported and may not meet all requirements of your coursework.

Internet Browser Settings

Please refer to your browser’s Help features to check these settings.

  • Pop-Up Blocker should be disabled
  • Java Script should be enabled
  • Java should be enabled
  • Cookies should be enabled

Plug-ins

The most recent version of the following plug-ins are required for many of the resources available in your online courses:

  • Adobe Flash Player
  • Adobe Acrobat Reader
  • Apple QuickTime Player
  • Java v7 or higher

All plug-ins needed to participate in components of your online classes are available at no additional cost. It is recommended that you review the list of plug-ins and install them prior to beginning your coursework.

Screen Settings

Your screen resolution (size) should be set at minimum 1024 x 768 or higher.